[Kea-users] Boost conflict while building Kea

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Kea-users] Boost conflict while building Kea

Gokulakrishnan Gopalakrishnan
I'm using boost1_48 to build kea. In my Centos6 box, I've installed boost 1_48. Here is my configure command. 
./configure --with-boost-include=/usr/include/boost148 --with-boost-lib-dir=/usr/lib64/boost148
I'm seeing this below-mentioned error while doing 'make'. There is already boost1_41 installed on the machine and I've installed 1_48 on top of it.
Looks like this have caused some conflicts for boost_system. Can someone helpme in resolving this conflicts?
17:49:09.585                           u'>>> /opt/rh/devtoolset-2/root/usr/libexec/gcc/x86_64-redhat-linux/4.8.2/ld: warning: libboost_system.so.1.48.0, needed by ../../../src/lib/asiolink/.libs/libkea-asiolink.so, may conflict with libboost_system.so.5\n',
17:49:09.585                           u">>> /opt/rh/devtoolset-2/root/usr/libexec/gcc/x86_64-redhat-linux/4.8.2/ld: main.o: undefined reference to symbol '_ZN5boost6system15system_categoryEv'\n",
17:49:09.585                           u">>> /opt/rh/devtoolset-2/root/usr/libexec/gcc/x86_64-redhat-linux/4.8.2/ld: note: '_ZN5boost6system15system_categoryEv' is defined in DSO /usr/lib64/libboost_system.so.1.48.0 so try adding it to the linker command line\n",
17:49:09.585                           u'>>> /usr/lib64/libboost_system.so.1.48.0: could not read symbols: Invalid operation\n',
17:49:09.585                           u'>>> collect2: error: ld returned 1 exit status\n',
17:49:09.585                           u'>>> make[6]: *** [kea-dhcp4] Error 1\n',

_______________________________________________
Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users