[Kea-users] Issue building Kea 1.4.0-beta - configure: error: Needs log4cplus library

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Kea-users] Issue building Kea 1.4.0-beta - configure: error: Needs log4cplus library

Chaigneau, Nicolas

Hello,

 

 

 

Executing configure with the following option :

 

--with-log4cplus

 

(directory which contains « include » and « lib » sub-dirs for Log4cplus)

 

 

This doesn’t seem to work for Kea 1.4.0-beta.

(It worked with Kea 1.3.0)

 

 

I get the following output :

 

checking log4cplus/logger.h usability... yes

checking log4cplus/logger.h presence... yes

checking for log4cplus/logger.h... yes

checking for log4cplus library... no

configure: error: Needs log4cplus library

 

 

 

 

Any idea ?

 

 

Regards,

Nicolas.

This message contains information that may be privileged or confidential and is the property of the Capgemini Group. It is intended only for the person to whom it is addressed. If you are not the intended recipient, you are not authorized to read, print, retain, copy, disseminate, distribute, or use this message or any part thereof. If you receive this message in error, please notify the sender immediately and delete all copies of this message.
_______________________________________________
Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users
Reply | Threaded
Open this post in threaded view
|

Re: [Kea-users] Issue building Kea 1.4.0-beta - configure: error: Needs log4cplus library

Francis Dupont
"Chaigneau, Nicolas" writes:
> Executing configure with the following option :
>
> --with-log4cplus
>
> (directory which contains < include > and < lib > sub-dirs for Log4cplus)
>
>
> This doesn't seem to work for Kea 1.4.0-beta.
> (It worked with Kea 1.3.0)

=> on which system?

> I get the following output :
>
> checking log4cplus/logger.h usability... yes
> checking log4cplus/logger.h presence... yes
> checking for log4cplus/logger.h... yes
> checking for log4cplus library... no
> configure: error: Needs log4cplus library
>
> Any idea ?

=> look at the config.log where the problem is logged with details.
Note we fixed in the past similar problems and if your compiler is
not C++11 compatible by default you can get spurious warnings
(this is why on my macOS I set the CXX environment variable to
"g++ --std=c++11" in the shell before calling autoreconf and ./configure.

Regards

Francis Dupont <[hidden email]>
_______________________________________________
Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users