[Kea-users] Kea 1.7.8 - HA-received data over unknown socket

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Kea-users] Kea 1.7.8 - HA-received data over unknown socket

Marcin Romanowski
I'm trying to run HA in v1.7.8 but in logs I have that error:

20.06.04 20:34:36.822 INFO  [kea-dhcp4.commands/2253] COMMAND_RECEIVED Received command 'ha-heartbeat'
20.06.04 20:34:46.842 ERROR [kea-dhcp4.packets/2253] DHCP4_BUFFER_RECEIVE_FAIL error on attempt to receive packet: received data over unknown socket
20.06.04 20:34:46.843 INFO  [kea-dhcp4.commands/2253] COMMAND_RECEIVED Received command 'ha-heartbeat'
20.06.04 20:34:56.865 ERROR [kea-dhcp4.packets/2253] DHCP4_BUFFER_RECEIVE_FAIL error on attempt to receive packet: received data over unknown socket
20.06.04 20:34:56.866 INFO  [kea-dhcp4.commands/2253] COMMAND_RECEIVED Received command 'ha-heartbeat'
20.06.04 20:35:06.881 ERROR [kea-dhcp4.packets/2253] DHCP4_BUFFER_RECEIVE_FAIL error on attempt to receive packet: received data over unknown socket
20.06.04 20:35:06.881 INFO  [kea-dhcp4.commands/2253] COMMAND_RECEIVED Received command 'ha-heartbeat'


I don't know where to search for a solution.

server 1 config and server 2 config have the same configuration, instead of ip and server name:
"Control-agent": {
    "http-host": "10.249.1.203",         // here 10.249.1.204 on server 2
    "http-port": 8000,
    "control-sockets": {
        "dhcp4": {
            "socket-type": "unix",
            "socket-name": "/opt/kea/var/run/kea/kea4-ctrl-socket"
        },
[...]

{
  "Dhcp4": {
    "authoritative": false,
    "calculate-tee-times": false,
    "control-socket": {
      "socket-name": "/opt/kea/var/run/kea/kea4-ctrl-socket",
      "socket-type": "unix"
    },
    "host-reservation-identifiers": [ "hw-address", "duid" ],
    "hostname-char-replacement": "",
    "hostname-char-set": "[^A-Za-z0-9.-]",
    "hosts-databases": [
      {
        "host": "localhost",
        "name": "kea",
        "password": "kea",
        "port": 5432,
        "readonly": true,
        "type": "postgresql",
        "user": "kea",
"reconnect-wait-time": 30000,
"max-reconnect-tries": 100000
      }
    ],
    "interfaces-config": {
      "dhcp-socket-type": "udp",
      "interfaces": [ "ens4" ],
      "re-detect": false
    },
    "lease-database": {
      "lfc-interval": 3600,
      "type": "memfile"
    },
    "loggers": [
      {
        "name": "kea-dhcp4",
        "output_options": [
          {
            "output": "/opt/kea/var/log/kea-dhcp4.log",
            "pattern": "%d{%y.%m.%d %H:%M:%S.%q} %-5p [%c/%i] %m\n"
          }
        ],
        "severity": "INFO"
      },
      {
        "name": "kea-dhcp4.ha-hooks",
        "output_options": [
            {
            "output": "/opt/kea/var/log/kea-hooks.log"
            }
        ],
        "severity": "DEBUG"
    }
    ],
    "match-client-id": false,
    "multi-threading": {
      "enable-multi-threading": false,
      "packet-queue-size": 64,
      "thread-pool-size": 0
    },
    "option-def": [ ],
    "rebind-timer": 2000,
    "renew-timer": 1000,
    "reservation-mode": "all",
    "sanity-checks": {
      "lease-checks": "fix-del"
    },
    "server-hostname": "",
    "server-tag": "",
"hooks-libraries": [{
        "library": "/opt/kea/lib/kea/hooks/libdhcp_lease_cmds.so",
        "parameters": { }
    }, {
        "library": "/opt/kea/lib/kea/hooks/libdhcp_ha.so",
        "parameters": {
            "high-availability": [{
                "this-server-name": "S1",      // S2 on server 2
                "mode": "hot-standby",
                "heartbeat-delay": 10000,
                "max-response-delay": 10000,
                "max-ack-delay": 5000,
                "max-unacked-clients": 0,
                "peers": [{
                    "name": "S1",
                    "url": "http://10.249.1.203:8000/",
                    "role": "primary",
                    "auto-failover": true
                }, {
                    "name": "S2",
                    "url": "http://10.249.1.204:8000/",
                    "role": "standby",
                    "auto-failover": true
                }]
            }]
        }
    }],
    "shared-networks": []


The same configuration works without error on v1.6.2

What I'm doing wrong?



_______________________________________________
ISC funds the development of this software with paid support subscriptions. Contact us at https://www.isc.org/contact/ for more information.

To unsubscribe visit https://lists.isc.org/mailman/listinfo/kea-users.

Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users