[Kea-users] Kea DHCPv4 1.4.0-P1 HA snchro error

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Kea-users] Kea DHCPv4 1.4.0-P1 HA snchro error

Ivan Stenda
Hello guys,

what mean these messages ? I got them after some restart of process and they disappear after two minutes ...


2018-10-08 09:58:31.384 INFO  [kea-dhcp4.ha-hooks/6369] HA_SYNC_START starting lease database synchronization with dhcp-12
2018-10-08 09:58:31.387 ERROR [kea-dhcp4.ha-hooks/6369] HA_LEASES_SYNC_FAILED failed to synchronize leases with dhcp-12 (http://10.58.0.12:8080/): internal server error: unable to parse server's answer to the forwarded message: Bad escape in <wire>:0:370, error code 1
2018-10-08 09:58:31.388 ERROR [kea-dhcp4.ha-hooks/6369] HA_SYNC_FAILED lease database synchronization with dhcp-12 failed: internal server error: unable to parse server's answer to the forwarded message: Bad escape in <wire>:0:370, error code 1


_______________________________________________
Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users
Reply | Threaded
Open this post in threaded view
|

Re: [Kea-users] Kea DHCPv4 1.4.0-P1 HA snchro error

Ivan Stenda
some lease updates are not working correctly, generating this log message:
2018-10-24 10:53:24.541 WARN  [kea-dhcp4.ha-hooks/20371] HA_LEASE_UPDATE_FAILED [hwtype=1 34:08:04:ac:53:22], cid=[01:34:08:04:ac:53:22], tid=0xa915: lease update to server101 (http://10.58.0.101:8080/) failed: body of the response must be a list

and this is view to failover communication for bad and correct updates:

POST / HTTP/1.1
Content-Length: 328
Content-Type: application/json
{ "arguments": { "client-id": "01:34:08:04:ac:53:22", "expire": 1540371418, "force-create": true, "fqdn-fwd": true, "fqdn-rev": true, "hostname": "D-Link\u0000", "hw-address": "34:08:04:ac:53:22", "ip-address": "10.187.15.132", "state": 0, "subnet-id": 2, "valid-lft": 120 }, "command": "lease4-update", "service": [ "dhcp4" ] }

HTTP/1.1 400 Bad Request
Content-Length: 40
Content-Type: application/json
Date: Wed, 24 Oct 2018 08:54:58 GMT
{ "result": 400, "text": "Bad Request" }

POST / HTTP/1.1
Content-Length: 318
Content-Type: application/json
{ "arguments": { "client-id": "01:48:62:76:92:02:ab", "expire": 1540371440, "force-create": true, "fqdn-fwd": false, "fqdn-rev": false, "hostname": "", "hw-address": "48:62:76:92:02:ab", "ip-address": "10.187.15.136", "state": 0, "subnet-id": 2, "valid-lft": 120 }, "command": "lease4-update", "service": [ "dhcp4" ] }

HTTP/1.1 200 OK
Content-Length: 50
Content-Type: application/json
Date: Wed, 24 Oct 2018 08:55:20 GMT
[ { "result": 0, "text": "IPv4 lease updated." } ]


how can I report this issue ?

regards
i




_______________________________________________
Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users
Reply | Threaded
Open this post in threaded view
|

Re: [Kea-users] Kea DHCPv4 1.4.0-P1 HA snchro error

Marcin Siodelski
Hello Ivan,

It seems that the following hostname: "D-Link\u0000" is the reason for
this error. Please create an issue in gitlab:

https://gitlab.isc.org/isc-projects/kea

Thank you,

Marcin Siodelski
ISC DHCP Engineering


On 25.10.2018 10:22, Ivan Stenda wrote:

> some lease updates are not working correctly, generating this log message:
> 2018-10-24 10:53:24.541 WARN  [kea-dhcp4.ha-hooks/20371]
> HA_LEASE_UPDATE_FAILED [hwtype=1 34:08:04:ac:53:22],
> cid=[01:34:08:04:ac:53:22], tid=0xa915: lease update to server101
> (http://10.58.0.101:8080/) failed: body of the response must be a list
>
> and this is view to failover communication for bad and correct updates:
>
> POST / HTTP/1.1
> Content-Length: 328
> Content-Type: application/json
> { "arguments": { "client-id": "01:34:08:04:ac:53:22", "expire":
> 1540371418, "force-create": true, "fqdn-fwd": true, "fqdn-rev": true,
> "hostname": "D-Link\u0000", "hw-address": "34:08:04:ac:53:22",
> "ip-address": "10.187.15.132", "state": 0, "subnet-id": 2, "valid-lft":
> 120 }, "command": "lease4-update", "service": [ "dhcp4" ] }
>
> HTTP/1.1 400 Bad Request
> Content-Length: 40
> Content-Type: application/json
> Date: Wed, 24 Oct 2018 08:54:58 GMT
> { "result": 400, "text": "Bad Request" }
>
> POST / HTTP/1.1
> Content-Length: 318
> Content-Type: application/json
> { "arguments": { "client-id": "01:48:62:76:92:02:ab", "expire":
> 1540371440, "force-create": true, "fqdn-fwd": false, "fqdn-rev": false,
> "hostname": "", "hw-address": "48:62:76:92:02:ab", "ip-address":
> "10.187.15.136", "state": 0, "subnet-id": 2, "valid-lft": 120 },
> "command": "lease4-update", "service": [ "dhcp4" ] }
>
> HTTP/1.1 200 OK
> Content-Length: 50
> Content-Type: application/json
> Date: Wed, 24 Oct 2018 08:55:20 GMT
> [ { "result": 0, "text": "IPv4 lease updated." } ]
>
>
> how can I report this issue ?
>
> regards
> i
>
>
>
>
>
> _______________________________________________
> Kea-users mailing list
> [hidden email]
> https://lists.isc.org/mailman/listinfo/kea-users
>

_______________________________________________
Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users