[Kea-users] cant change lease timers during lease4_select

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Kea-users] cant change lease timers during lease4_select

itay cohen
hi guys

i'm trying to change the lease timer during the  lease4_select hook,
i get an unexpected behavior:

        lease4_ptr->valid_lft_ = 8677; <- for some reason only this works, i see it on the lease DB and the client
        lease4_ptr->t1_ = 555;  <- this one doesn't give an error but does not work,  on the client i see the original timer
        lease4_ptr->t2_ = 777; <- this one doesn't give an error but does not work,  on the client i see the original timer

please advise

thank you
itay,


_______________________________________________
Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users
Reply | Threaded
Open this post in threaded view
|

Re: [Kea-users] cant change lease timers during lease4_select

Francis Dupont
itay cohen writes:
> i'm trying to change the lease timer during the  lease4_select hook,
> i get an unexpected behavior:
>
>         lease4_ptr->valid_lft_ = 8677; <- for some reason only this works,
> i see it on the lease DB and the client
>         lease4_ptr->t1_ = 555;  <- this one doesn't give an error but does
> not work,  on the client i see the original timer
>         lease4_ptr->t2_ = 777; <- this one doesn't give an error but does
> not work,  on the client i see the original timer

=> first formally only the valid lifetime is a lease property, T1 and T2
belong to the address info/IA. Second I looked at the code and the subnet
values are used, i.e. it seems the values in the lease are for info only...
Of course you can change them at a later hook point.

Regards

Francis Dupont <[hidden email]>
_______________________________________________
Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users