[Kea-users] dhcp4 server on IP unnumbered interfaces

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Kea-users] dhcp4 server on IP unnumbered interfaces

avoy
This post was updated on .
Hi,

I am seeing an issue running kea-dhcp4 (1.7.1) on multiple interfaces configured as
ip unnumbered.

Here is my interface configuration. rt1_0_1 and rt1_0_2 are both sharing
the same IP address on a loop[back interface.

rt1_0_1   Link encap:Ethernet  HWaddr 50:9a:4c:e9:c0:73
          inet addr:192.168.200.2  Bcast:192.168.200.2  Mask:255.255.255.255
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

rt1_0_2   Link encap:Ethernet  HWaddr 50:9a:4c:e9:c0:73
          inet addr:192.168.200.2  Bcast:192.168.200.2  Mask:255.255.255.255
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

When I run kea-dhcp4 on rt1_0_1 and rt1_0_2, it complains while opening
socket for rt1_0_2 as 192.168.200.2:67 is already used for rt1_0_1.

If I configure to run kea-dhcp4 only on loopback interface then it does not
listen on rt1_0_1 and rt1_0_2 and the dhcp requests are dropped.

Is there a way to make kea-dhcp4 work in this use case?

Thanks,
Avoy

_______________________________________________
Kea-users mailing list
Kea-users@lists.isc.org
https://lists.isc.org/mailman/listinfo/kea-users