[Kea-users] kea & log4cplus

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Kea-users] kea & log4cplus

bill.pye
Hi Everyone

I'm currently using kea on CentOS8 and have a little question. I'm seeing the following messages when I do a system upgrade:

Problem 2: cannot install the best update candidate for package isc-kea-libs-1.9.2-isc0009720201123144834.el8.x86_64
  - problem with installed package isc-kea-libs-1.9.2-isc0009720201123144834.el8.x86_64
  - package isc-kea-libs-1.9.2-isc0009720201123144834.el8.x86_64 requires liblog4cplus-1.1.so.9()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package log4cplus-1.1.3-0.4.isc1.el8.x86_64
  - cannot install both log4cplus-1.2.0-11.el8.x86_64 and log4cplus-1.1.3-0.4.isc1.el8.x86_64
  - cannot install both log4cplus-1.1.3-0.4.isc1.el8.x86_64 and log4cplus-1.2.0-11.el8.x86_64

Obviously this is a test kea-1.9 but I see the same messages for the kea-1.8 version, is kea actually built to use a specific version of log4cplus and if so, why? Wouldn't it be better to use the O/S available version of log4cplus rather than a specific version or have I messed something obvious here?

Do forgive me if my questions is a bit basic but I'm just a home user of kea and somewhat inexperienced.

Regards

Bill


Sent with ProtonMail Secure Email.


_______________________________________________
ISC funds the development of this software with paid support subscriptions. Contact us at https://www.isc.org/contact/ for more information.

To unsubscribe visit https://lists.isc.org/mailman/listinfo/kea-users.

Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users
Reply | Threaded
Open this post in threaded view
|

Re: [Kea-users] kea & log4cplus

Wlodek Wencel

Hello,

this is very interesting info, reason why there is a log4cplus-1.1.3-0.4.isc1.el8.x86_64 pkg created by us is simple - there we no such package when we first released kea on centos 8. And we wanted to make it easier. We will be releasing 1.9.3 very soon, if time allows I will make that change, if not we will address this in 1.9.4.

Thanks for using Kea and reporting this to us.

Regards

Wlodek Wencel

ISC QA

On 13/12/2020 13:50, bill.pye wrote:
Hi Everyone

I'm currently using kea on CentOS8 and have a little question. I'm seeing the following messages when I do a system upgrade:

Problem 2: cannot install the best update candidate for package isc-kea-libs-1.9.2-isc0009720201123144834.el8.x86_64
  - problem with installed package isc-kea-libs-1.9.2-isc0009720201123144834.el8.x86_64
  - package isc-kea-libs-1.9.2-isc0009720201123144834.el8.x86_64 requires liblog4cplus-1.1.so.9()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package log4cplus-1.1.3-0.4.isc1.el8.x86_64
  - cannot install both log4cplus-1.2.0-11.el8.x86_64 and log4cplus-1.1.3-0.4.isc1.el8.x86_64
  - cannot install both log4cplus-1.1.3-0.4.isc1.el8.x86_64 and log4cplus-1.2.0-11.el8.x86_64

Obviously this is a test kea-1.9 but I see the same messages for the kea-1.8 version, is kea actually built to use a specific version of log4cplus and if so, why? Wouldn't it be better to use the O/S available version of log4cplus rather than a specific version or have I messed something obvious here?

Do forgive me if my questions is a bit basic but I'm just a home user of kea and somewhat inexperienced.

Regards

Bill


Sent with ProtonMail Secure Email.


_______________________________________________
ISC funds the development of this software with paid support subscriptions. Contact us at https://www.isc.org/contact/ for more information.

To unsubscribe visit https://lists.isc.org/mailman/listinfo/kea-users.

Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users

_______________________________________________
ISC funds the development of this software with paid support subscriptions. Contact us at https://www.isc.org/contact/ for more information.

To unsubscribe visit https://lists.isc.org/mailman/listinfo/kea-users.

Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users
Reply | Threaded
Open this post in threaded view
|

Re: [Kea-users] kea & log4cplus

bill.pye
Hi

Thanks for that info and I'll look forward to the 'fix' when it's available.

Regards

Bill


Sent with ProtonMail Secure Email.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Monday, 14 December 2020 10:52, Wlodek Wencel <[hidden email]> wrote:

Hello,

this is very interesting info, reason why there is a log4cplus-1.1.3-0.4.isc1.el8.x86_64 pkg created by us is simple - there we no such package when we first released kea on centos 8. And we wanted to make it easier. We will be releasing 1.9.3 very soon, if time allows I will make that change, if not we will address this in 1.9.4.

Thanks for using Kea and reporting this to us.

Regards

Wlodek Wencel

ISC QA

On 13/12/2020 13:50, bill.pye wrote:
Hi Everyone

I'm currently using kea on CentOS8 and have a little question. I'm seeing the following messages when I do a system upgrade:

Problem 2: cannot install the best update candidate for package isc-kea-libs-1.9.2-isc0009720201123144834.el8.x86_64
  - problem with installed package isc-kea-libs-1.9.2-isc0009720201123144834.el8.x86_64
  - package isc-kea-libs-1.9.2-isc0009720201123144834.el8.x86_64 requires liblog4cplus-1.1.so.9()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package log4cplus-1.1.3-0.4.isc1.el8.x86_64
  - cannot install both log4cplus-1.2.0-11.el8.x86_64 and log4cplus-1.1.3-0.4.isc1.el8.x86_64
  - cannot install both log4cplus-1.1.3-0.4.isc1.el8.x86_64 and log4cplus-1.2.0-11.el8.x86_64

Obviously this is a test kea-1.9 but I see the same messages for the kea-1.8 version, is kea actually built to use a specific version of log4cplus and if so, why? Wouldn't it be better to use the O/S available version of log4cplus rather than a specific version or have I messed something obvious here?

Do forgive me if my questions is a bit basic but I'm just a home user of kea and somewhat inexperienced.

Regards

Bill


Sent with ProtonMail Secure Email.


_______________________________________________
ISC funds the development of this software with paid support subscriptions. Contact us at https://www.isc.org/contact/ for more information.

To unsubscribe visit https://lists.isc.org/mailman/listinfo/kea-users.

Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users



_______________________________________________
ISC funds the development of this software with paid support subscriptions. Contact us at https://www.isc.org/contact/ for more information.

To unsubscribe visit https://lists.isc.org/mailman/listinfo/kea-users.

Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users