[Kea-users] kea-dhcpv6 handing out prefix instead of IP address

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Kea-users] kea-dhcpv6 handing out prefix instead of IP address

IT TroubleMan
Hello,

running kea-dhpcv6 version 1.9.5.

Excerpt from my config:
                     
"subnet6": [ { "subnet": "aaaa:bbbb:cccc:dddd::/64", "pools": [ { "pool": "aaaa:bbbb:cccc:dddd::/80" }  }]

Problem is that a client (Windows 7) gets aaaa:bbbb:cccc:dddd:: as its IP address.
I activated debuglog with 99 verbosity and found no warning or error, it just hands out aaaa:bbbb:cccc:dddd::
Client gets DNS servers successfully.

Network uses DHCP relay. M and O flags are set.
In other networks/VLANs with same configuration but different DHCPv6 server it works without any problem.

Thanks for your advices.

John

_______________________________________________
ISC funds the development of this software with paid support subscriptions. Contact us at https://www.isc.org/contact/ for more information.

To unsubscribe visit https://lists.isc.org/mailman/listinfo/kea-users.

Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users
Reply | Threaded
Open this post in threaded view
|

Re: [Kea-users] kea-dhcpv6 handing out prefix instead of IP address

Joelson Vendramin

Hi John,

I think that when you're specifying the pool as a network ({ "pool": "aaaa:bbbb:cccc:dddd::/80" }), kea is assuming that the very first IPv6 is a "valid" one.

Try specifying the pool as a range of IPv6, or, at least configure an exception (not to serve) the address ...::0 of /80.

Regards,

Joelson

Em 18/03/2021 10:25, IT TroubleMan escreveu:
Hello,

running kea-dhpcv6 version 1.9.5.

Excerpt from my config:
                     
"subnet6": [ { "subnet": "aaaa:bbbb:cccc:dddd::/64", "pools": [ { "pool": "aaaa:bbbb:cccc:dddd::/80" }  }]

Problem is that a client (Windows 7) gets aaaa:bbbb:cccc:dddd:: as its IP address.
I activated debuglog with 99 verbosity and found no warning or error, it just hands out aaaa:bbbb:cccc:dddd::
Client gets DNS servers successfully.

Network uses DHCP relay. M and O flags are set.
In other networks/VLANs with same configuration but different DHCPv6 server it works without any problem.

Thanks for your advices.

John

_______________________________________________
ISC funds the development of this software with paid support subscriptions. Contact us at https://www.isc.org/contact/ for more information.

To unsubscribe visit https://lists.isc.org/mailman/listinfo/kea-users.

Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users

_______________________________________________
ISC funds the development of this software with paid support subscriptions. Contact us at https://www.isc.org/contact/ for more information.

To unsubscribe visit https://lists.isc.org/mailman/listinfo/kea-users.

Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users
Reply | Threaded
Open this post in threaded view
|

Re: [Kea-users] kea-dhcpv6 handing out prefix instead of IP address

Francis Dupont
In reply to this post by IT TroubleMan
IT TroubleMan writes:
> running kea-dhpcv6 version 1.9.5.
>
> Excerpt from my config:
>
> "subnet6": [ { "subnet": "aaaa:bbbb:cccc:dddd::/64", "pools": [ { "pool":
> "aaaa:bbbb:cccc:dddd::/80" }  }]
>
> Problem is that a client (Windows 7) gets aaaa:bbbb:cccc:dddd:: as its IP
> address.

=> it is the first address of the pool so it is not an error. Note

the easiest way to remove an address from a pool is to reserve it to
a nonexistent host.

Thanks

Francis Dupont <[hidden email]>
_______________________________________________
ISC funds the development of this software with paid support subscriptions. Contact us at https://www.isc.org/contact/ for more information.

To unsubscribe visit https://lists.isc.org/mailman/listinfo/kea-users.

Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users