[Kea-users] (no subject)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Kea-users] (no subject)

Mike Carlson

For greater visibility, I'm posting here, as I have also submitted a gitlab issue here:
https://gitlab.isc.org/isc-projects/kea/issues/1047

The tl;dr is Kea DHCP4 is not sending subnet options to clients and we don't know why.

We have paid for the premier hooks, so were running kea with the mysql configuration backend for hosts, subnets and leases. This is a dhcp4 only environment.

Our environment consists of around 300 subnets

We have a test host with a out of band management device that is set to use our new kea server via dhcp helper address.

If we update kea, via posting a subnet config to the agent controller, for this management network, we can restart the out-of-band management device and it gets an address and a gateway

If we add a few more subnets, again, posting a subnet config to the agent controller, we can restart the OOB device and it gets an IP address and a gateway

This is where things get weird.

If we add all 300+ subnets, and restart the OOB device, it does not get a gateway. It gets a leased ip address, but no subnet options.

Our packet captures during these events shows our OOB device requesting a gateway, but kea never sends one or any of the other options


_______________________________________________
Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users
Reply | Threaded
Open this post in threaded view
|

Re: [Kea-users] (no subject) && Subnets stored in mysql_cb don't consistently work

Chad Catlett


> On Dec 10, 2019, at 15:50, Mike Carlson <[hidden email]> wrote:
>
> For greater visibility, I'm posting here, as I have also submitted a gitlab issue here:
> https://gitlab.isc.org/isc-projects/kea/issues/1047
>
> The tl;dr is Kea DHCP4 is not sending subnet options to clients and we don't know why.
>
> We have paid for the premier hooks, so were running kea with the mysql configuration backend for hosts, subnets and leases. This is a dhcp4 only environment.
>
> Our environment consists of around 300 subnets
>
> We have a test host with a out of band management device that is set to use our new kea server via dhcp helper address.
>
> If we update kea, via posting a subnet config to the agent controller, for this management network, we can restart the out-of-band management device and it gets an address and a gateway
>
> If we add a few more subnets, again, posting a subnet config to the agent controller, we can restart the OOB device and it gets an IP address and a gateway
>
> This is where things get weird.
>
> If we add all 300+ subnets, and restart the OOB device, it does not get a gateway. It gets a leased ip address, but no subnet options.
>
> Our packet captures during these events shows our OOB device requesting a gateway, but kea never sends one or any of the other options
>
> _______________________________________________
> Kea-users mailing list
> [hidden email]
> https://lists.isc.org/mailman/listinfo/kea-users

Sorry I did not realize that Mike was sending an email at the same time as me.

Both of our emails are about the same issue.

Chad
_______________________________________________
Kea-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/kea-users